Skip to content Skip to sidebar Skip to footer

mengamankan mikrotik dari serangan Bruteforce

Daftar Isi [Tutup]
    sebelum kita menuju langkah-langkah untuk mengamankan mikrotik kita dari serangan Bruteforce, alangkah lebih baiknya kita sedikit mengenal apa itu Bruteforce. jika menurut sahabat bocah komputer Bruteforce itu apa sih??? jika dari segi arti Bruteforce merupakan paksaan, jadi disini Bruteforce merupakan serangan yang di lakukan oleh seorang hacker untuk membobol password atau keamanan dengan cara mencoba setiap password hingga akhirnya hacker tersebut menemukan password yang tepat. umumnya seorang peretas akan menggunakan algoritma yang menggabungkan simbol, huruf, dan angka untuk mendapatkan password sebagai persiapan untuk menyerang keamanan mikrotik kita, sebagai contoh percobaan menggunakan kata "password" yang di tulis dan dikombinasikan dengan simbol sehingga menjadi "p@$$word".

    Biasanya  para peretas yang menggunakan cara ini telah memiliki wordlist dalam jumlah yang sangat banyak untuk menebak kemungkinan password yang tepat. sehingga serangan ini dapat memakan waktu hingga beberapa menit, beberapa bulan, atau bahkan beberapa tahun tergantung dari seberapa kuat password yang digunakan oleh target sasaran.
    maka sebelum Sahabat Bocah Komputer melakukan konfigurasi Mikrotik ke Internet, alangkah baiknya kita memberikan keamanan awal terlebih dahulu. Agar mikrotik kita tidak mudah untuk di serang, yang bisa sahabat bocah komputer baca di artikel 10 Langkah awal menjaga keamanan Mikrotik.

    Setelah 10 Langkah awal menjaga keamanan Mikrotik telah sahabat Bocah Komputer Terapkan maka pada Artikel kali ini, penulis akan memberikan sedikit trik untuk mencegah Brute Force Login pada Mikrotik kita.

    Mari kita perhatikan gambar berikut :


    Dari sisi user tentunya log informasi pada gambar tersebut pasti akan sangat mengganggu karena log akan mencatat semua aktifitas yang terjadi pada mikrotik kita, termasuk client yang mencoba login ke mikrotik. Kemudian dari sisi mikrotik juga akan membebani resource dari mikrotik ketika terdapat banyak client yang hendak mengakses mikrotik kita secara Bruteforce.

    Langkah selanjutnya yang bisa kita lakukan untuk mengamankan Router dari serangan Bruteforce setelah sahabat bocah komputer menerapkan 10 Langkah awal menjaga keamanan Mikrotik yaitu dengan cara sebagai berikut : 
    1. menandai alamat IP penyerang kemudian di drop, cara ini kita bisa memanfaatkan fitur firewall pada Mikrotik Kita.

    2. Mengamankan FTP dari serangan Bruteforce dengan cara sebagai berikut, yang bisa langsung sahabat bocah komputer copy kemudian di pastekan di mikrotik yang sahabat gunakan.

    /ip firewall filter
    add chain=input protocol=tcp dst-port=21 src-address-list=ftp_blacklist action=drop
    comment="drop ftp brute forcers"

    add chain=output action=accept protocol=tcp content="530 Login incorrect" dst-limit=1/1m,9,dst-address/1m

    add chain=output action=add-dst-to-address-list protocol=tcp content="530 Login incorrect"
    address-list=ftp_blacklist address-list-timeout=3h


    Pada konfigurasi diatas, maka yang kita peroleh ialah ketika ada Seseorang yang mencoba login melalui FTP ke mikrotik kita lebih dari 10 kali gagal, maka IP Address dari Orang tersebut akan di drop selama 3 jam. Konfigurasi dapat sahabat bocah komputer sesuaikan dengan yang di butuhkan.

    3. Menon-aktifkan Remote SSH dengan cara sebagai berikut yang bisa langsung sahabat bocah komputer copy paste.

    add chain=input protocol=tcp dst-port=22 src-address-list=ssh_blacklist action=drop
    comment="drop ssh brute forcers" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new
    src-address-list=ssh_stage3 action=add-src-to-address-list address-list=ssh_blacklist
    address-list-timeout=10d comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new
    src-address-list=ssh_stage2 action=add-src-to-address-list address-list=ssh_stage3
    address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new src-address-list=ssh_stage1
    action=add-src-to-address-list address-list=ssh_stage2 address-list-timeout=1m comment="" disabled=no

    add chain=input protocol=tcp dst-port=22 connection-state=new action=add-src-to-address-list
    address-list=ssh_stage1 address-list-timeout=1m comment="" disabled=no


    Maka yang kita dapatkan konfigurasi diatas, ketika ada User yang mencoba meremote Mikrotik kita melalui SSH dan mengalami gagal login selama lebih dari 3 kali, maka alamat IP User tersebut akan di drop selama 10 Hari. Konfigurasi ini dapat Sahabat Bocah Komputer sesuaikan dengan yang di butuhkan.

    Post a Comment for "mengamankan mikrotik dari serangan Bruteforce"